The Facebook/Twitter/Google app client ID and app secret should be migrated by a data migration from the configuration table into the new "services" table.
The admin screen needs to present a drop-down listing the services applicable to each provider - e.g. the Facebook section should list all services of type "facebook."
When any of the following is hit, if there is no "service" selector for each social provider, the configuration option should be disabled:
admin screen
login screen
The Facebook/Twitter/Google app client ID and app secret should be migrated by a data migration from the configuration table into the new "services" table.
The admin screen needs to present a drop-down listing the services applicable to each provider - e.g. the Facebook section should list all services of type "facebook."
When any of the following is hit, if there is no "service" selector for each social provider, the configuration option should be disabled:
* admin screen
* login screen
aheathershaw
added this to the Version 2.2.0-beta.2 milestone 2020-04-28 22:08:08 +01:00
This will also resolve an issue where a social network can be enabled and used for login/registration even if no app ID/secret has been provided - resulting in a 500 server error.
This will also resolve an issue where a social network can be enabled and used for login/registration even if no app ID/secret has been provided - resulting in a 500 server error.
Data migration to move the config from the settings table to the services table
Add a link to the config screen underneath the services dropdown to the services screen
Last 2 things left to do for this:
* [x] Data migration to move the config from the settings table to the services table
* [x] Add a link to the config screen underneath the services dropdown to the services screen
Blocking a user prevents them from interacting with repositories, such as opening or commenting on pull requests or issues. Learn more about blocking a user.
The Facebook/Twitter/Google app client ID and app secret should be migrated by a data migration from the configuration table into the new "services" table.
The admin screen needs to present a drop-down listing the services applicable to each provider - e.g. the Facebook section should list all services of type "facebook."
When any of the following is hit, if there is no "service" selector for each social provider, the configuration option should be disabled:
This will also resolve an issue where a social network can be enabled and used for login/registration even if no app ID/secret has been provided - resulting in a 500 server error.
Last 2 things left to do for this: